remembird frozen with one green light showing

Need any help using RememBird, the application or any add-ons?

remembird frozen with one green light showing

Postby gregpoole on Wed Sep 29, 2010 9:24 am

My remembird is frozen with one green light showing (second from left, if left is 0%). If I take out battery and then plug it into PC it freezes on the same light. This happened after re-uploading a custom audio guide, overwriting previous version in that 'slot'
all best from Greg
gregpoole
 
Posts: 9
Joined: Sun Sep 19, 2010 6:04 pm

Re: remembird frozen with one green light showing

Postby gregpoole on Wed Sep 29, 2010 11:00 am

Further to last post, should also say that the remembird software isn't recognising the device when plugged into PC. The one green light is on and battery is removed.
all best from Greg
gregpoole
 
Posts: 9
Joined: Sun Sep 19, 2010 6:04 pm

Re: remembird frozen with one green light showing

Postby cblair on Thu Sep 30, 2010 9:42 am

Hi Greg,

First step is to try the single-step startup procedure - which often tells us what's going on.

1. Battery out to make sure it's really off (rather than on but no lights showing).
2. Hold the joystick to the left (rewind) and plug into USB.
3. You should see a single green light (the 0% one).
4. Release the joystick - it's now in single-step mode.
5. Press and release the song record button. The lights should change.
6. Repeat until you get a fixed pattern for more than 16 presses OR the lights ripple and it becomes visible to your PC/Mac.
7. In the former case, tell me what the pattern of lights was. In the latter, use the app to refresh the firmware with latest build (Help > Force Firmware Update).

Best regards
Chris
Chris B (the inventor)
cblair
Site Admin
 
Posts: 191
Joined: Fri Apr 25, 2008 6:10 am
Location: East Sussex, United Kingdom

Re: remembird frozen with one green light showing

Postby gregpoole on Thu Sep 30, 2010 10:36 am

Hi Chris, thanks for advice. I can get to the rippling lights stage which then starts autorun for remembird software. I make the firmware upgrade but the frozen green light stage is resumed.
I've tried this several times and sometimes the rippling lights were only at the right (3 lights) and then the single green one (second from left).
If I try loading the audio fieldguides before firmware upgrade it says "version not supported. please contact...... for free upgrade etc".
This may be because after notice of software update yesterday I tried doing that? That was after the freeze-up.
Just tried again and now see that after the upgrade (which is OK'd on screen) the lights become fixed , with 2 being green and 5 red. and that takes me back to the beginning if I unplug it.
all best from Greg
gregpoole
 
Posts: 9
Joined: Sun Sep 19, 2010 6:04 pm

Re: remembird frozen with one green light showing

Postby cblair on Thu Sep 30, 2010 10:45 am

OK - so RememBird isn't dead, it's just trying to tell us something - which is a bit of a challenge when you only have 7 LEDs to play with.
The patterns you've described give me the clues I need to go find out what's up.

Let me digest the above and get back to you - probably tomorrow.
Chris B (the inventor)
cblair
Site Admin
 
Posts: 191
Joined: Fri Apr 25, 2008 6:10 am
Location: East Sussex, United Kingdom

Re: remembird frozen with one green light showing

Postby gregpoole on Thu Sep 30, 2010 11:37 am

One more clue Chris. By using your one step system with the remembird on battery only, I got it to the work normally (after the rippling lights and many presses of the song record button). The only thing that didn't work was my amended custom audio library... My own announcement for that had a glitch in it and then no usable content... the other libraries(one of mine, and the european birds) worked fine.
If I then turned it off and plugged it into the computer or just turn back on again it goes to the no.2 green light and no.5 is now red. (the red light is also there after the firmware upgrade procedure).
all best from Greg
gregpoole
 
Posts: 9
Joined: Sun Sep 19, 2010 6:04 pm

Re: remembird frozen with one green light showing

Postby gregpoole on Thu Sep 30, 2010 2:54 pm

I managed to get the device working by using your one step procedure when it was not plugged into the USB. So it is now performing normally except for the libraries.
I attempted to reload my modified custom audio library which had been in slot 3. Slot 3 was no longer visible in the drop down list so it seems that has some how been corrupted. At first when it was loaded into slot 4 some weird aberrations happened where when playing back through the remembird software announcements from the european guide were playing when songs from my custom guide should have played.
On the remembird itself my new slot 4 guide seems to work ok now but there is just a vestige of the old slot 3 version which does nothing other than give a slightly title scrambled announcement.
So the new question would be 'what happened to slot 3.
If I try to load the libraries then I get the first screenshot error message shown here.
000011.png
000011.png (10.28 KiB) Viewed 10761 times
Despite that I am able to access the european bird library, and the one labelled orthoptera as shown in the second screen shot.
000012.png
000012.png (7.88 KiB) Viewed 10795 times

In the ui. properties folder the only library listed was the south african birds... all the others greyed out had been over written.
Hope all this helps solving issues with building the custom libraries.
all best from Greg
gregpoole
 
Posts: 9
Joined: Sun Sep 19, 2010 6:04 pm

Re: remembird frozen with one green light showing

Postby cblair on Fri Oct 01, 2010 6:49 pm

Hi Greg,

I've been trying to replicate your steps but no joy.
Found one minor thing - which is that if you go back to the download dialog again without having closed the app down, the drop-down list of slots is showing the previous state (e.g. slots 2-7 all clear) and then the new state (slot 2 filled, 3-7 clear). Corrected that ready for next patch.

I've downloaded my North African one a couple of times now and don't see the problem you describe.
Might be worth you zipping me the contents of your Libraries folder so I can see if there's anything suspicious there?
I can give you an FTP site to upload that to. Will email credentials to you.

I agree that the level of home-recorded announcements is a bit low in comparison with the ones on the pre-loaded guide. I'll turn the level up a bit on those. If you want to tweak ones you've already done, you can either re-record them or you can run the mp3 through Audacity in batch mode and "normalize" them to 0dB.

What size is your South African guide? There's a limit of 100MB at present on home-made ones (due to work on increasing that next week).
Chris B (the inventor)
cblair
Site Admin
 
Posts: 191
Joined: Fri Apr 25, 2008 6:10 am
Location: East Sussex, United Kingdom

Re: remembird frozen with one green light showing

Postby DaveCurtis on Sat Oct 02, 2010 4:48 pm

Hi Chris,
My Remembird also froze with the second green and red light on. After three attempts with your unlocking method I finally managed to unlock it and download my recordings.

My very small Homemade Fieldguide (4 species) also has very loud white noise instead of the announcements but the calls are there. When I hold down the play button for 2 seconds I get the "European Birds" announcement, white noise and then usually white noise or sometimes, and more helpfully, the "First recording", "Last recording" announcements. I would be very happy to get rid of the homemade guide and get the standard announcements back.

I tried to rebuild the fieldguide several times and the announcements sounded OK on the laptop but still awful white noise on the remembird.

Is it possible to delete Homemade Fieldguides? If not there will be a lot of recorders containing redundant 'test' fieldguides.

Dave
DaveCurtis
 
Posts: 11
Joined: Thu May 20, 2010 4:08 pm

Re: remembird frozen with one green light showing

Postby cblair on Sat Oct 02, 2010 5:29 pm

Hi Dave,
Glad it got going again.
Can you tell me what version of program and firmware you're on? (Help > About RememBird should show this).

The white noise in your announcements almost certainly means you have sound card that reverses the order of the bytes. We've not been able to find a way of determining this programmatically but a small proportion of sound cards need the following line of magic to be added to your properties file.

Under your RememBird directory, is a sub-directory "props" and in there is a text file "ui.properties" that you can edit with notepad. Do this when the program is NOT running (or it will overwrite your changes when it exits).

Add the following line:

LameEncoderReverseBits=true

(btw - there's a patch coming out next week that will increase the volume of newly recorded announcements to match the pre-recorded ones better).
Chris B (the inventor)
cblair
Site Admin
 
Posts: 191
Joined: Fri Apr 25, 2008 6:10 am
Location: East Sussex, United Kingdom

Next

Return to Support

Who is online

Users browsing this forum: No registered users and 5 guests

cron